Boton no funciona en mozilla

Crear páginas para Gecko, diferencias con IE, articulos de interés y recursos en español
aguerra

Boton no funciona en mozilla

Mensajepor aguerra » Mar Nov 10, 2009 8:35 am

Hola a todos,

He creado una web y me funciona en todos los navegadores bien todo menos una cosita en firefox. El problema es que para acceder a la web es necesario una contraseña. En firefox no me deja ni siquiera pulsar al botón enviar...por lo tanto no puedo acceder al contenido de la web. ¿A que se puede deber éste problema?

Adjunto a continuación el código html para que lo veais.

Código: Seleccionar todo

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<title>xxxx</title>
<meta name="keywords" content="" />
<meta name="description" content="" />
<link href="style.css" rel="stylesheet" type="text/css" media="screen" />
<script type="text/javascript">
  <!--

   function Validar(form){
   
if(formulario.passw.value == "valencia"){
          formulario.submit();}else {
                                     alert("Incorrecto");
                                   }
   }
function valida(e){
tecla=(document.all) ? e.keyCode : e.which;
if(tecla == 13) {
alert("Pulse el boton Enviar")
return false;
}
}


  -->
</script>


<p align="center"><b>
<style>
.spanstyle {
    position:absolute;
    visibility:visible;
    top:-50px;
    font-size:12pt;
    font-family:Verdana;
    font-weight:bold;
    color:steelblue;
}
</style>
<style type="text/css">
h1{color:#FFFFFF; text-align:center}
h2{color:red; text-align:center}
table{background-color:#99055FF;
      text-align:center;
margin-left: auto;
margin-right: auto;
}
.final{
font-size:8pt;
color:red;}
.final2{
font-size:8pt;
color:steelblue;}


</style>
</head>
<body>

<div id="menu" >
   <blockquote>
   <div align="center" ><h1>BODA </h1></div>
     <p>&nbsp;</p>
     
  </blockquote>
</div>
<div id="page"><br />
<div align="center" ><h2>Bienvenidos</h2></div>

<div align="center"  >
<img src="images/novios.jpg" width="130" heigth="130" /></div>


            <form action="portada.html" method="post" id="formulario">
             
          
               <table border="3" cellpadding="2" cellspacing="2" align="center" width="400" heigth="300"  >
               
                  <tr>
                     <td>CONTRASE&Ntilde;A </td>
                  <td><input type="text" name="passw" size="10" onkeypress="return valida(event)" /></td>
                  </tr>
                  <tr>
                     <td  colspan="2">
                                                                          
                                                                  <input type="button" name="Envio" value="Enviar" onclick="Validar(this.form)"/>                  
              <input type="reset" name="Borrar" value="Borrar"/>
                </td>
                </tr>
              </table>
            </form>
   
<br /><br />

</div>
<!-- end page -->

<div id="footer">

<div id="footer">

<hr color="#000033" />
<table align="center" width="911" >
<tr>
<td width="489"  >
<p align="center" class="legal">Ana Hern&aacute;ndez ....... 658697946</p></td>
<td width="410"  >
<p align="center" class="legal">Federico Bros ....... 606334830</p></td>
</tr>
<tr>
<td  >
<p align="center" class="legal">anaha1983@hotmail.com</p></td>
<td  >
<p align="center" class="legal">federico.bros@gmail.com</p></td>
</tr>
</table>   
<hr color="#000033" />   
   
   
</div>
</div>   

<br /><br /><br /><br />
<table align="center" cellspacing="1" cellpadding="10" >
<tr>
<td width="150" ><p align="center" class="final" >Created by &Aacute;ngeles Bros: </p></td>

<td width="150" ><p align="center" class="final2" >angelesbros@gmail.com</p></td>
</tr>
</table>

</body>
</html>




Muchisimas gracias de antemano!!!

Lhotse

Re: Boton no funciona en mozilla

Mensajepor Lhotse » Mar Nov 10, 2009 9:18 am

aguerra escribió: En firefox no me deja ni siquiera pulsar al botón enviar...por lo tanto no puedo acceder al contenido de la web. ¿A que se puede deber éste problema?

Tú solución está a un simple click: http://validator.w3.org/

aguerra

Re: Boton no funciona en mozilla

Mensajepor aguerra » Mar Nov 10, 2009 11:11 am

ya lo he validado y no me dice nada al respecto...


Volver a “Desarrollo web (HTML/CSS/JS, accesibilidad...)”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado