Problemas con flash en firefox y la tag embed

Crear páginas para Gecko, diferencias con IE, articulos de interés y recursos en español
Firexero

Problemas con flash en firefox y la tag embed

Mensajepor Firexero » Jue Dic 09, 2004 3:49 pm

Hace poco estoy usando este navegador, sobre todo porque trabajo haciendo páginas y el firefox sigue todas las recomendaciones y estandares de la W3C... salvo uno!
Cuando pones un flash en tu html, para q sea valido (4.01) solo debes hacerlo con la etiqueta OBJECT, pero el firefox no lo ve si no tiene ademas una EMBED, que eso hace q no sea HTML4.01 valido.
¿Alquien sabe de alguna solucion o de q el equipo de mozilla sepa de esto?
Desde ya los saludo agradecido.

Avatar de Usuario
galio
Gran Mozilla
Gran Mozilla
Mensajes: 17288
Registrado: Dom Sep 14, 2003 1:22 am
Ubicación: Argentina
Contactar:

Mensajepor galio » Jue Dic 09, 2004 3:55 pm

OBJECT debería funcionar sin problemas, según lo que tengo entendido, si está todo bien escrito. Muevo el hilo al foro correspondiente, que en este caso es Desarrollo web ;).

Avatar de Usuario
Flextron
Dragón de Komodo
Dragón de Komodo
Mensajes: 697
Registrado: Jue Ago 28, 2003 10:44 pm
Ubicación: Barcelona
Contactar:

Mensajepor Flextron » Jue Dic 09, 2004 4:12 pm

¿Seguro?

Código: Seleccionar todo

< o bject type="application/x-shockwave-flash" data="/flash.swf" id="menu-en-flash">
< p aram name="quality" value="high" />
< p aram name="bgcolor" value="#FFFFFF" />
< / o bject>

Puedes ponerle más parametros a la pelicula, son opcionales.
Última edición por Flextron el Jue Dic 09, 2004 4:27 pm, editado 1 vez en total.
Mozilla/5.0 (compatible;Konqueror/3.4;Linux) KHTML/3.4.0,Gecko
Noticias de Mozilla en Mozillazine
«Amigo, intenta no ocupar tu vida en odiar y tener miedo» (Sthendal, Lucien Leuwen)

Avatar de Usuario
galio
Gran Mozilla
Gran Mozilla
Mensajes: 17288
Registrado: Dom Sep 14, 2003 1:22 am
Ubicación: Argentina
Contactar:

Mensajepor galio » Jue Dic 09, 2004 4:15 pm

Flex, pasa algo raro con el HTML, vamos a ver qué pasa, pero por lo pronto dejá un espacio entre < y el nombre de la etiqueta para que no desaparezca ;). Digo que pasa algo raro, porque todo desaparece, tanto las etiquetas permitidas, como las no permitidas.

Avatar de Usuario
Flextron
Dragón de Komodo
Dragón de Komodo
Mensajes: 697
Registrado: Jue Ago 28, 2003 10:44 pm
Ubicación: Barcelona
Contactar:

Mensajepor Flextron » Jue Dic 09, 2004 4:28 pm

Vaya, al final lo que he tenido que pegar con el Konqueror, a Firefox parece que no le gustaba...
Mozilla/5.0 (compatible;Konqueror/3.4;Linux) KHTML/3.4.0,Gecko
Noticias de Mozilla en Mozillazine
«Amigo, intenta no ocupar tu vida en odiar y tener miedo» (Sthendal, Lucien Leuwen)

Firexero

Solucionado!

Mensajepor Firexero » Sab Dic 11, 2004 9:10 pm

Mil gracias!! el problema esta en el Dreamweaver que pone la ruta del archivo como un parametro opcional y no como data.

Firexero

si les sirve

Mensajepor Firexero » Sab Dic 11, 2004 9:31 pm

Para q ande en explorer y firefox en la etiqueta object hay q poner type="application/x-shockwave-flash" data="suarchivo" y si quieren las medidas con width y height.
En los parametros hay q poner uno con el nombre "movie" y de value su archivo nuevamente, asi me funciono a mi.
Tuve q sacar el classid y el codebase sino no se veia en firefox, es raro porq son dos valores estandarizados, pero asi anda, q mejor! GRACIAS DE NUEVO!!!

JesseRangel

Solución al problema con firefox

Mensajepor JesseRangel » Mar Dic 11, 2012 2:52 am

Muchas gracias amigo, ese comentario es del 2004, pero ahorita en el 2012 me sirvió para solucionar ese problema, ahora todo me funciona bien thanks.


Volver a “Desarrollo web (HTML/CSS/JS, accesibilidad...)”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados