Como puedo forzar que funcionen los complementos antiguos en Firefox Quantum

Foro sobre los plugins y las diferentes extensiones que permiten ampliar las posibilidades de las aplicaciones Mozilla
javier29esp

Como puedo forzar que funcionen los complementos antiguos en Firefox Quantum

Mensajepor javier29esp » Jue Nov 30, 2017 4:15 am

Hola
Tengo cientos de pestañas guardadas con con complemento de Firefox que se llama Session Manager. Es un complemento muy popular y todo el mundo lo usa:
https://addons.mozilla.org/es/firefox/a ... n-manager/
En estos cientos de pestañas está toda la información de investigación para mi tesis en la universidad.
Al actualizarse Firefox a la versión 57, Quantum, este complemento no funciona y he perdido todas las pestañas.
Estoy dispuesto a hacer lo que sea por recuperarlas, ya que afectaría a mi carrera, se cargaría toda mi tesis, tendría que empezar desde cero, serí horroroso.
¿Hay alguna forma de forzar que funcionen los complementos antiguos o por lo menos este complemento en concreto en Firefox Quantum?
¿Si no es posible, hay alguna posibilidad de instalar de forma aislada, sin interferir con Firefox 57, un Firefox más antiguo al que le pueda meter la extensión? Lo pregunto por lo menos para recuperar las pestañas.
Y si esto no es posible, ¿hay alguna forma de recuperar esta información del complemento Session Manager?
Saludos







[Movido] a Extensiones y Plugins

Avatar de Usuario
ElTxolo
Moderador
Moderador
Mensajes: 8922
Registrado: Sab Feb 19, 2005 5:48 pm
Ubicación: Localhost
Contactar:

Re: Como puedo forzar que funcionen los complementos antiguos en Firefox Quantum

Mensajepor ElTxolo » Jue Nov 30, 2017 11:37 am

    Imagen Tienes varias opciones:

  • Lo primero. No puedes hacer funcionar las extensiones antiguas XPCOM/XUL en Firefox 57+

  • Instalar una extensión como MySessions y/o Tab Session Manager compatibles con Firefox 57+
    Que además, tienen la posibilidad, de importar las antiguas sesiones de SessionManager:

    Código: Seleccionar todo

     MySessions - Version 2.2
     
    New features:
    - Import saved sessions from an extension "Session Manager" (which can not yet be implemented for FF57+).
    - Autosaving sessions on a schedule.


    Código: Seleccionar todo

    Tab Session Manager - Version1.5.0

        Added Sessions import / export function.
        It also supports SessionManager's session file (.session).

  • Instalar una versión anterior (en la que te funcione perfectamente la extensión), como Firefox 56.0.2 o Firefox 52.5.0 ESR





    PD. Hagas lo que hagas, NO olvides hacer una copia de seguridad del Perfil de usuario, antes de nada.









    Un Saludo. Imagen
ImagenImagen

Imagen
Imagen Imagen
Cómo hacer preguntas inteligentes ;)

[Mozilla/5.0 (X11; Linux x86_64; en-US; rv:52.0) Gecko/20180205 SeaMonkey/2.49.2]
[Mozilla/5.0 (X11; Linux x86_64; en-US; rv:54.0) Gecko/20170619 SeaMonkey/2.51]

cocute
Visitante frecuente
Visitante frecuente
Mensajes: 47
Registrado: Mar Nov 14, 2006 8:56 pm

Re: Como puedo forzar que funcionen los complementos antiguos en Firefox Quantum

Mensajepor cocute » Vie Dic 01, 2017 1:03 pm

Pues si, la verdad es que como instales la 57 encima de una versión vieja y luego quieras volver a la viaja se hace un poco de lio,
mantiene los addons nuevos que no van y tienes que buscar los addons viejos por otro lado para reinstalarlos.

Esto Firefox debería avisarlo cuando se aunto-instala la 57 sin avisar.

ynyse
Gecko
Gecko
Mensajes: 80
Registrado: Mié Nov 09, 2005 7:03 pm

Re: Como puedo forzar que funcionen los complementos antiguos en Firefox Quantum

Mensajepor ynyse » Mar Dic 05, 2017 2:06 am

¿Donde tengo que poner ese código?

Por qué cuando las cosas funcionan bien las complican :'(

Avatar de Usuario
ElTxolo
Moderador
Moderador
Mensajes: 8922
Registrado: Sab Feb 19, 2005 5:48 pm
Ubicación: Localhost
Contactar:

Re: Como puedo forzar que funcionen los complementos antiguos en Firefox Quantum

Mensajepor ElTxolo » Mar Dic 05, 2017 12:36 pm

ynyse escribió:¿Donde tengo que poner ese código?

    Imagen El código, no lo tienes que poner en ningún sitio.

    Es simplemente informativo, para saber que a partir de la versión versión 2.2 de MySessions,
    puedes importar las sesiones que has guardado previamente, con la antigua extensión SessionManager








    Un Saludo. Imagen
ImagenImagen

Imagen
Imagen Imagen
Cómo hacer preguntas inteligentes ;)

[Mozilla/5.0 (X11; Linux x86_64; en-US; rv:52.0) Gecko/20180205 SeaMonkey/2.49.2]
[Mozilla/5.0 (X11; Linux x86_64; en-US; rv:54.0) Gecko/20170619 SeaMonkey/2.51]


Volver a “Extensiones y plugins”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados