Súbita incompatibilidad de certificados. Ultimas versiones

Utilizar el navegador Mozilla Firefox
Avatar de Usuario
Tomeu
Moderador
Moderador
Mensajes: 3756
Registrado: Jue Dic 09, 2004 5:52 pm
Ubicación: A sa roquete

Súbita incompatibilidad de certificados. Ultimas versiones

Mensaje por Tomeu » Mié Abr 03, 2019 2:17 pm

En mi equipo con SO LInux (Linux Mint 19.1 Tessa) últimamente noté que Firefox (ver 66.0.x 64 bits) estaba fallando cuando quería usar el certificado del DNIe.
En cambio con el otro navegador Firefox que tengo allí instalado (ver 52.9.x ESR por lo del java en unas concretas páginas) no había problema.
Tampoco hay problema con SeaMonkey (2.49.4 64 bits), ni con Chrome.
En todos esos navegadores aparte del dispositivo de seguridad correspondiente al DNIE está el de la tarjeta criptográfica ACA.
Con esta última no hay problema.
En la versión de FF 66.0.x si desinstalo el dispositivo de seguridad ACA, pues el del DNIE automáticamente vuelve a funcionar.

Hoy he probado cómo era el comportamiento con mi otro equipo con Windows Pro 10 (1809), y sorprendentemente pasa lo mismo si se trata de Firefox, en sus versiones 66.0.x y 60.6.x ESR
Es decir, si desinstalo el dispositivo de la otra tarjeta criptográfica la del DNIe vuelve a funcionar. La de ACA funciona, tanto si está sola como acompañada de la del DNIe.
Lo probé también con la última versión de la rama release 65.x.x y el fallo fue el mismo.
Con Chrome no se da ese problema (Edge e I.Explorer son problema en sí)
Probé con SeaMonkey 2.49.4 (solo hay versión de 32 bits), y al principio dispositivos DNIe y ACA parecían coexistir sin problemas, ahora el del DNIe solo funciona si está solo.

El síntoma es que el navegador queda en una especie de bucle eterno tras introducir la contraseña del DNIe para identificarse, debiendo forzar el cierre (con Firefox 66.0.2 y 60.6.0 ESR en Windows y 66.0.2 en linux)

El fallo con SeaMonkey 2.49.4 (Win 32 b) es que se cierra el navegador y surge la ventana de error de aplicación.

Tanto en Linux como en Windows he creado nuevos perfiles por si se trataba de que estuviera allí el fallo. Sin efecto. Se produce el fallo igual con perfiles nuevos como viejos.

¿Alguna sugerencia o pista para encontrar solución?

PD: No sé desde qué versión de FF se da este fallo, pues tampoco uso las tarjetas criptográficas a diario, además casi siempre uso la ACA que "no se queja" de compartir perfil con DNIe; pero lo cierto es que no hace mucho (quizás con FF 62 ó 63 todo estaba funcionando bien). Los certificados son los mismos, no ha habido ningún cambio (tampoco están caducados: de hecho el DNIe funciona perfecto si no tengo instalado el otro)

=-O

Avatar de Usuario
Tomeu
Moderador
Moderador
Mensajes: 3756
Registrado: Jue Dic 09, 2004 5:52 pm
Ubicación: A sa roquete

Re: Súbita incompatibilidad de certificados. Ultimas versiones

Mensaje por Tomeu » Sab Abr 06, 2019 9:33 am

Imágenes del fallo.

Si tengo 2 dispositivos de seguridad / tarjetas instalados:
admdor_dispositivos.png
admdor_dispositivos.png (31.2 KiB) Visto 162 veces
El DNIe deja de funcionar; tras introducir contraseña y en el paso final nunca llega a abrise la página segura
fallo_dnie.png
fallo_dnie.png (14.89 KiB) Visto 162 veces


Avatar de Usuario
Tomeu
Moderador
Moderador
Mensajes: 3756
Registrado: Jue Dic 09, 2004 5:52 pm
Ubicación: A sa roquete

Re: Súbita incompatibilidad de certificados. Ultimas versiones

Mensaje por Tomeu » Sab Abr 06, 2019 2:14 pm

Gracias.

Esas páginas no me solucionan nada. Como digo el fallo con el DNIe solo se da si tengo 2 tipos de tarjetas criptográficas instaladas (como he tenido desde hace años sin ningún problema hasta hace unas semanas).

Si desinstalo "descargo" el "dispositivo" tarjeta ACA, sin necesidad de reiniciar el navegador el DNIe vuelve a funcionar.

La tarjeta ACA funciona tanto si está como única instalada, como si también está el DNIe.

Solución práctica y chapucera por ahora: tener un perfil para el DNIe y un perfil para la tarjeta ACA.

En fin

(Ah!. En linux conviven bien y sin queja DNIe y ACA, en FF 52.9.0 ESR y SeaMonkey 2.49; el problema ha sido desde alguna de las últimas versiones de FF, ya release 66, 65 ó 64, ya ESR 60)

Alguna pijada en el tema de la seguridad ha provocado este fallo.

Avatar de Usuario
Tomeu
Moderador
Moderador
Mensajes: 3756
Registrado: Jue Dic 09, 2004 5:52 pm
Ubicación: A sa roquete

Re: Súbita incompatibilidad de certificados. Ultimas versiones

Mensaje por Tomeu » Jue Abr 11, 2019 9:04 am

Hoy he actualizado la versión de FF a la 66.0.3 en windows 10.

El mismo problema continúa.

Resumen de la incompatibilidad en Windows entre dispositivo de seguridad del DNIe y de la tarjeta ACA:

.............. ACA+DNIe

Firefox 66.x:... NO dnie (1)

Edge:............ NO dnie (2)

Chrome:......... ok

SeaMonkey: ..... NO dnie (3)

I.Explorer:....... ok

(1) si se retira el dispositivo ACA, DNIe funciona
(2) DNIe no funciona casi nunca
(3) si se retira el dispositivo ACA, DNIe funciona. SM 32 bits

Resumen de la incompatibilidad en Linux entre dispositivo de seguridad del DNIe y de la tarjeta ACA:

.............. ACA+DNIe

Firefox 66.x:... NO dnie (1)

Firefox 60 ESR:. NO dnie (1)

Firefox 52.x ESR.. ok

Chrome:......... ok

SeaMonkey: ..... ok (2)

(1) si se retira el dispositivo ACA, DNIe funciona
(2) SeaMonkey 64 bits

Editado 07/05/19: SeaMonkey en Linux ya ha dejado de funcionar :-/

Responder